Ограничение доступа к документам и справочникам

12.06.2017 5625 39 470

Эта разработка позволяет настроить выборочную блокировку (открытия или изменения) справочников и документов для разных пользователей (или групп пользователей).

Тут вы можете спросить - А не проще ли обойтись установкой нужных ролей для пользователей?

Отвечаю - не всегда. Нередко типовые роли являются избыточными, и в придачу к установке нужных прав для пользователей предоставляют им дополнительные ненужные полномочия. К тому же иногда бывает нужно ограничить возможность редактирования уже проведенных документов - такую задачу типовыми средствами не решить.

Расширение позволяет дополнить функциональность типовых ролей конфигурации и в пользовательском режиме ограничить доступ конкретных пользователей (или групп) к конкретным типам объектов системы (документам или справочникам).

Для примера, ограничим конкретному пользователю доступ к документу Заказ клиента:

Откроем форму настройки прав доступа:

все функции

Нас интересует регистр сведений Ограничение доступа к данным:

ограничение доступа к данным

После этого откроется список настроек, создаем новую:

настройка ограничения доступа

На форме настроек выбираем:

  • тип объекта - документ или справочник,
  • имя объекта - в данном случае выбираем из выпадающего списка нужный тип документов информационной базы, типы документов информационной базы
  • настраиваем адресата ограничения - можно выбрать конкретного пользователя или группу пользователей (в таком случае ограничение будет срабатывать для всех пользователей, принадлежащих этой группе),
  • тип запрета - запрет открытия или запрет изменения (в последнем случае форма будет открываться только на просмотр, таким образом пользователь не сможет редактировать старый документ).

Теперь попытка пользователя открыть заказ заканчивается ничем:

ограничение доступа к документам

Ограничение не распространяется на пользователей с полными правами.

Разработка работает только на следующих релизах:

  • Управление торговлей - 11.4.6.166 и выше,
  • Комплексная автоматизация и ERP - 2.4.6.166 и выше,

Релиз платформы 1С должен быть не ниже 8.3.12.

Покупка разработки

Способ оплаты

Нажимая на кнопку "Оплатить", вы даете согласие на обработку своих персональных данных.
Не удается оплатить?
Смотрите также
Комментарии (0)
Капча введена неверно Введите капчу
Группа в контакте Группа в Facebook Группа в контакте Группа в Twitter Группа в Одноклассниках